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1. BBFlashBack overview 
 

BBFlashBack is a Windows-based screen recording programme, distributed by Blueberry 

Software.  The programme allows users to record and edit computer screen actions and 

audio files; embed images, audio files and videos, add text effects, cut and paste movie 

footage and edit mouse movements.  BBFlashBack can produce short videos in different 

formats such as Flash, AVI, WMV, or EXE format.   

 1.1 Main functions 

 

The programme provides video and audio recording tools with limited editing options. It 

contains one video (timeline) track and several audio tracks that can be added. Main 

BBFlashBack functions include: Record (Video, Audio) – Edit (Video, Audio, Text) – Import 

(video, audio, image & text) – Produce (FLV, SWF, AVI, WMV and EXE format). 

   

1.2 Starting a BBFlashBack programme    

Click on ‘BBFlash icon‟  on your desktop if you have a short cut there; or  

Start > Programs > Blueberry Software > BBFlashBack Pro > BBFlashBack Pro Recorder: 

 

2. Recording a movie 

2.1 Recording a new movie 

 

  

     

 

 

 

 

1. Plug your microphone and open BBFlashBack and 

click on Record a new movie and use the 6-step 

recording settings below. 
 

 

Exercise 1: Record a screencast. Search for articles about bees and dance in 

Library Search and record including these screens: Library home page, Library 

Search, search box and typing in bees and dance, first screen of results. 
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If you are planning to record a sound or a voiceover at 
the same time while you are recording a screen action, 
plug in a microphone into your PC and tick this option. 
 
Test the microphone by speaking and monitoring the 
green stripe that indicates the sensitivity of the device. 
If there is no movement on the scale, this indicates that 
your microphone is not operating. 

22.05 kHz is the optimal sound format for 
streamed videos. 

Select both Stereo and MP3 Compression. This 
will improve the sound quality of your recording. 
Click Next 

You can either let BBFlashBack adjust 
the settings for you (recommended) or 
choose your own settings by selecting 
one of the three options in this box or 
click More settings, then, click Next. 
 

This is disabled because there is no webcam 
installed. You can tick this option if you have a 
webcam installed on your PC. Click Next. 
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2. The recording red square will appear with the „Record‟ pop-up box on your screen, you 

need to move the recoding red square and click „Record‟ as shown 2 steps below: 
             

  

 

 

 

3. Record your screen movement. Once you click „Record‟. BBFlashBack will start recording 

all the screens and cursor movement within the recording red square until you stop it.  

4. Click the Stop button to stop recording at the bottom of your desktop:  

Step 1 Move and resize the recording red 
square to make sure all the browser windows 
that you‟d like to record are covered. 

Step2 Click Record  

Record the complete desktop 
area. 

Record only a pop-up 
window. 

Record selected region of the desktop. This is 
the most flexible option as it allows manual 
modification of the screen resolution. 

Tick this option to have the Recorder 
toolbar displayed at the bottom of the 
desktop. This is handy as you can use it to 
easily start and stop recording and change 
the settings. 

The Recorder toolbar will be displayed in the 

middle of the desktop, in front of any other 
images or folders. This can be distracting 
and may affect the recording procedure, so 
don’t tick it. 

Recap exercise 1: Record a new video: Search for articles about bees and dance 

in Library Search, including these screens: Library home page, Library Search, 
search box and typing in bees and dance, first screen of results. 
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5. Click Save when a pop-up window appears or click Discard if you 

are not satisfied with the recording. Name the video and save it 

to desktop. It will be automatically saved in BBFlashBack movie 

file (*.fbr) format.  

6. You can export the video or review or edit it now. Click Open in Player to open and vie 

it, then you can edit it. 

 

 
 

7. The BBFlashBack playing/editing window will open automatically for you to play or edit 

the movie.  You can click on the Pause  button to stop playing.   

2.2 Recording a video using a webcam camera  

If you have a webcam camera set up on your PC, you can create a BBFlashBack video 

recording of yourself, save it as a BBFlashBack video file and embed it into your 

screencasts. To do this, double click on the BBFlashBack Recorder, click Record a new 

movie and select the screen resolution of your new video. If you have a headset with a 

microphone plugged into the PC, select relevant Sound Settings to record the voiceover at 

the same time as your video. Select the following WebCam Recording settings and use 

Test WebCam button to preview the position of web camera: 

 

 

 
  

Keep clicking Next till the Record Movie button 

appears on the screen and start recording. You 

will notice that the video preview window is not 

available while the webcam is recording. Click 

 and save new .fbr video. You may edit it 

in BBFlasBack Player and insert it into your 

screencast using the Insert >> FlashBack 

movie command. 
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3. Editing a movie 
 

When you open an existing movie or screencast in BBFlashBack, you can play it and edit it.  

The main BBFlashBack screencast editing tools are accessible under the main Edit menu 

and will also appear by right clicking on a selected frame in the timeline menu. 

3.1 BBFlashBack tools 

    The BBFlashBack toolbars are shown below. 

 

                                                           

3.2 Playing and editing your screencast 

1. Play and stop: Click the Play   button on the BBFlashBack Player timeline and review 

the screencast recorded in Exercise 1. 

2. Delete frames: when you play a movie or screencast, video frames are displayed at the 

top of the screen.  You can delete any unwanted frames by selecting or highlighting them 

and clicking the Delete  button or using the Delete key.  

  

 

E.g. if you want to delete some frames between the word “e” and “s” as shown below “bees 

and dance”, you can highlight 8 frames between and delete these frames as shown below. 

 

 

 

3. Insert frames:  You can also insert frames by clicking the Insert Frame  button or go 

to Edit > Insert Frames 

 

Editable sound track Editable movie timeline 
One video frame (18 frames = 1 
second of the movie duration) 

BBFlashBack menu bars 

Select or highlight these frames and delete them 

2. Delete Frames 

1. Select or highlight frames 

Timeline 

BBFlashBack tool bars 
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3.3 Insert a text and an image 

You can insert a text or an image into your existing movie or screencast.  You can do this by 

going to the Edit menu or by right clicking on the selected frame in the timeline menu: 

 

 

 

 

 

 

 

1. Select the first frame on the timeline:  

2. Insert > Text…: 

              

3. Type your text message and select duration in the Insert Text pop-up menu, click 

OK. 

 

Insert the text and edit tool 

Pause the movie at the selected frame. Viewers need to click on 
it to continue. This option is ONLY useable in videos 
produced in .swf format. 

Import an image or a photo  

Link text or an image to a URL. This option is ONLY 
useable in videos produced in .swf format. 
 

Exercise 2: Insert frames with a duration of 2.5 seconds at the beginning of your  

screencast.  Tip: select the first frame on the timeline and then insert frames. 

Exercise 3: Insert a text at the beginning of your movie or screencast.  

 

Changing the duration of the video: 
You can either change the number of frames or the 
duration in seconds. Changing the duration in seconds 
is recommended as the number of frames will be 
changed accordingly. 
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4. You can resize or reposition the text box to fit your screen.   

5. You can edit your text box by double clicking on the text box.   

6. The inserted text signs    appear on the movie timeline to indicate the duration 

of the textbox; you can move these signs to change the position or the duration of 

the text box. 

 

 

 

 

1. Select the frame that contains the end of the text appearance sign ; 

2. Insert 56 frames (=4 seconds) 

3. Insert > Insert Image…; 

4. Click  to select an image (for this class activity, you can upload an image 

from the folder: Desktop\BBFlash Class Exercises); 

5. Increase the duration of the image to 4 seconds or at your choice; 

6. You can click the Transitions tab and set the Fade In and Fade Out timing e.g. for 0.20 – 

0.50 seconds 

7. Click the Position tab and put 0 in both left and top position to make the inserted image 

to appear on the top of the screen and click „OK’.  You can resize or reposition the image 

by clicking and dragging. 

Type in the title of your video, select 
the font type & colour; e.g. Verdana, 
size 18pt – 36pt. 

Select the shape of the textbox. 

Select the duration of the textbox on 
the timeline. Make sure that it matches 
the duration of previously added video 
sequence. 

You can select textbox fade in and 
fade out animation options. 

To ensure that you will be able to see 
new textbox on the screen, go to the 

Position menu and click

. 

Select the colour of the background. 

Exercise 4: Insert an image after the text box.  Follow the steps below. 
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8. The inserted image signs  will appear on the movie timeline to indicate the duration 

of the image.  You can move these signs to change the position or the duration of the 

image as shown below.  

 

 Tip: If the inserted image is smaller than the screen, you can insert a button to cover  

          the background: Insert >   

 

 

 

1. Select an appropriate frame within the image signs  , for example, the 10th frame 

away from the image sign ;  

2. Insert >>   

3. Select the shape of the new textbox:  on the pop-up menu. Type in the 

speech wording, e.g. “The course is really useful. I can find articles much faster than 

before!” 

 

4. Select a font size and font type and select duration (e.g. 2.5 sec, a bit shorter than 

the duration of the inserted image) 

5. Click the Transitions tab and set the Fade In and Fade Out timing e.g. for 0.20 – 

0.50 seconds  

6. Click OK. 

7. Resize the text cloud on the screen and position it onto the image as shown below.  

 

Increase the 
duration to 4 sec 

Exercise 5: Insert a speech text cloud on top of the inserted image by 

following the steps below. 
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3.4 Hiding recorded mouse clicks  

While recording a screencast, you may select 

the option to automatically highlight all 

performed mouse clicks. This action appears 

as a blinking red circle next to the cursor in 

the final production. However, this may be a 

distracting occurrence in some sequences.                                            

You do not need to delete frames to remove it; 

instead you can use the following toolbar to rectify it: 

 
 

3.5 Inserting Zoom/Pan 

BBFlashBack allows you to “zoom in” to any area of the movie and more clearly show a 

particular screen action.  You can insert zoom/pan by following the steps below. 

1. Select a frame that you‟d like to zoom into. 

2. Effect >  

3. Select the Custom Area on the pop-up menu. This will 

enable you to select the zoom area manually. Select 

Custom and then time the zoom effect to the duration of the 

sequence you are emphasising. Click OK. 

4. A green square will appear on the BBFlashBack screen. 

Reposition it and resize manually to the part of the 

screencast you are zooming into. 

5. Scroll forward on the timeline and select the frame that you‟d like to end the 

zoom/pan effect, then return to the full screen view.  

6. Repeat step 2 in this exercise, but instead of selecting the Custom Area, make sure 

to tick the Whole movie option. 

7. Adjust the timing to 1 second. 

8. Preview the complete movie by selecting the  option at the top toolbar 

menu and then . 

3.6 Looping the video 

If you wish to set your video so that it keeps looping while you are editing it using 

BBFlashBack , or as a finished and produced screencast, select Movie                    

(at the top BBFlashBack Player menu) >> Loop. 

 

3.7 Embedding a URL in a video 

BBFlashBack allows you to embed a URL into a video.  You can embed a URL in your video 

and create a „stop button‟ by following the steps below. 

1. Select the last video frame on the timeline.  
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2. Go to Insert > Insert Button. 

3. On the pop-up menu, select the following options: 

  

4. Click OK and Save . 

After the final production of the screencast, viewers will be able to click on this button within 

the video and, for example, go directly to the Library Workshops webpage and book the 

session. 

 

 

 

 

4. Recording, editing & inserting an audio file 
 

BBFlashBack enables you to record audio using a microphone plugged into your PC while 

you are recording a screencast.  You can also record audio after you have recorded your 

screencast.  BBFlashBack also allows you to insert or import additional WMA, mp3 audio or 

music files.  The audio, or voice recording, can be edited within the separate audio timeline.  

 

4.1 Recording an audio file 

You can go to Sound menu > Record Sound to record audio. 

 

 
 

1. Prepare a written script or an outline for your narration. Plug a headphone set with a 

microphone into your PC.  

2. Select the frame on the BBFlashBack timeline where the screen 

action starts.  

3. Go to Sound menu at the top and select Record Sound as shown 

on the right. 

4. On the pop-up menu, select the following options and click Record: 

Exercise 6: Record and edit a new audio file. Follow the steps below. 

Type in the text: “Click here to book this 
session” and select the font type, size, 
colour and the background colour. 

Your screencast will pause as 
soon as the button appears and 
viewers will need to click on it to 
continue the movie. 

You can type in a URL link that viewers will be 
able to connect to by clicking on the button.  

IMPORTANT: Make sure to open the 
Position menu and change all margins 
to 0, otherwise you may not be able to 
see the new button on the screen. 

NOTE:  The „stop button‟ and URL functions are applicable ONLY in the BBFlashBack 

screencasts produced in SWF or EXE format. 
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5. To stop recording sound, click  at the top. Your voice recording will automatically 

appear in new audio track on the timeline. Click  to play it. 

 

4.2 Editing audio tracks 

1. Remove unwanted parts of the audio recording: click on the audio track (it will 

change to the pink colour when the sound track is selected); select some sound 

tracks and delete them by using keyboard or right click on the selection and select 

Delete on the drop-down menu.   

 

A pop-up box will appear. Select the following 

options and click OK and Save . 

 

2. Split the audio tracks:  

1) Select the audio track that you want to split from; Right click and select as 

shown below.  

 

 

 

 

 

 

 

2) You can then split the sound or move the split sound to another place 

 

 

Audio track 

It is pink when 

the track is 

selected 
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3. Volume up/down: 1) Click  to go to the end of the timeline. 

Select the music track and drag and drop your cursor so that 

the last part of the music file is selected; 

 

 

 

2) Right click on it and select the Volume up or Volume down command. Repeat this 

step again to reduce the volume further. Replay the sequence to hear the 

difference. 

4. Other audio editing tools:  select parts of the audio track and 1) cut  or copy

 and past  them into the second track; 2) reposition and merge   them; 

You may also increase the volume levels by using the  tool. 

 

4.3 Inserting or importing an audio or music file 

  

BBFlashBack allows you to insert or import an additional audio file, e.g. background music 

file.  You can do this by going to Insert menu >  

 

 

 

1. Select the very first video frame on the timeline.  

2. Go to Insert > .  

3. Using the pop-up window, select and import the WMA music file from your desktop 

BBFlash Course exercises folder or from your own sound folder. 

Exercise 7: Insert a background audio file into your screencast. Follow the  

                   steps below. 
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4. Click OK. 

5. The background audio track appears on the BBFlashBack timeline as shown below: 

 

6. Click Play  and preview the complete movie. 

 

. 

 

 

5. Importing a BBFlashBack video 

You can record several different screencasts and save them as separate .fbr BBFlashBack 

files. The programme allows you to import and combine two or more BBFlashBack videos, 

edit them on the same timeline, and cut and paste selected frames from one video into 

another.  

 

 

 

 

1. Select the last frame on the BBFlashBack timeline. 

2. Go to Insert > FlashBack Movie. 

3. Select the Ursula.fbr video in the BBFlash Course folder on Desktop and click 

Open. Wait until the video is downloaded into the timeline.  

4. The third audio track will appear.  If the sound recording of the imported video is not 

loud enough, you can select it and increase the volume. 

Exercise 8: Insert or import a BBFlashBack video at the end of your screencast.  

                   Follow the steps below. 

 

Note: You will notice that the audio track has the same duration as the video track 

The background music may interfere with the voice recording, so you may want to 

reduce the volume of the newly imported music file. 
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5.1 Importing picture–in–picture video: AVI & WMV formats 

You can embed videos in other formats (apart from .fbr), such as AVI & WMV. They can be 

imported as picture–in–picture elements, where inserted video can be moved and positioned 

anywhere on the original FBR video screen and resized - so that the embedded video 

appears as another window in your screencast. 

 

 

 

1. Select the last frame of the video you are creating. Insert additional frames (40 

additional seconds). 

2. Go to Insert > Webcam Picture-In–Picture Video > From AVI, WMV video file... 

        

3. Navigate to the video file you wish to insert.  

        

4. Select the COURSE VENUE.wmv video in the BBFlash Course folder on Desktop 

and click Open. Wait until the video is downloaded into the timeline.  

5. Make sure that the Import soundtrack function is selected on the Import menu. 

6. Click Import. 

7. Reposition and resize the inserted video on the .FBR video screen as you prefer. 

8. Click Save . You can export completed video in FLV, SWF, AVI, WMV etc video 

formats as needed.  

 

6. Exporting and producing your video  
 

Once the video is completed, you need to combine all the images, text, audio and video and 

export them into one file. This process is called production. 

 

 

1. File menu > Export: 

Exercise 10: Produce your video by following the steps below. 

 

Exercise 9: Embed a picture-in-picture AVI or WMV video into your screencast. 
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2. You need to check with Library‟s Web Manager for recommended format you can 

produce your video in. You can select WMV for this class activity. 
 

 

3. Select General, Video, Audio to choose product settings as shown below: 

 

 

 

 

       

 

Use this option when producing 
a number of screencasts at the 
same time. 

This option produces a flash video embedded into a blank 
PowerPoint presentation. 

Before producing a video in flash format, check whether 
your PC has a Flash Player or Adobe Flash CS5 programme 
installed. 

Use the „smallest file size‟ if you 
are producing only a pilot video to 
be sent in an email for viewing. If 
you are producing a video to be 
streamed from a website, select 
Custom or Full frame rate. 

When producing a video in AVI or WMV format, 
you will need to select a codec to be encoded into 
the audiovisual file. Codec is a software that 
enables your computer to play the video.                                                 
You can download all relevant codecs onto your 
computer as free applications from the web and 
save them on your C drive. This is the list of 
codecs available in BBFlashBack when you are 
producing a video in the WMV format. 
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4. Click on Export and save the video file on your desktop or drive, wait for the „export‟ 

procedure to be completed, and preview the final product. 

7. Making your video available via Cecil 

     You can link the url of your video and make it available via Cecil. Otherwise, you can  

     upload the video as separate file by following the steps below. 

 

1. Video must be encoded as .wmv file. 

2. Login into Cecil. Select the course from the course navigation pane on the left of the 

screen.  

  

3. Click on the Resources tab.  

4. Click on the New button in the toolbar. A New File Resource dialog window 

appears. Type in a title for the file in the Name field, e.g. Lecture 1. 

5. Enter the dates (timeframe) that you would like this file to be available using the 

Visible from: and Visible to: fields.  

6. If you wish to hide the file temporarily from the students, untick the checkbox Is 

this visible to the students.  

7. Click on Browse and find the video file you wish to upload. 

  

8. Click on the Save button in the toolbar at the top of the window. 

9. On the Course Resources Cecil page select the Lecture 1 file and click on the 

Download button.   
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7.1 Uploading your video to a webpage 

Email your video uploading request with the video file attached to   

web-request@lbr.auckland.ac.nz. 

 

8. Creative Commons 

Creative Commons is a non-profit organization (http://creativecommons.org/), US based 

and founded in 2001. It provides four main Creative Commons Copyright licenses 

(http://creativecommons.org/about/licenses) that address the open source distribution 

flexibility and allow the use and modification of licenced digital content within the 

international legal framework. These four basic licenses can be combined to produce eleven 

valid Creative Commons licenses. 

9.1 Creative Commons Aotearoa New Zealand Licenses (CCANZ) 

New Zealand is the 41st country to officially launch its Creative Commons licenses. For more 

information, visit: http://creativecommons.org.nz. Six licenses (3 non-commercial and 3 

commercial) have been designed by legal experts in intellectual property law for use in the 

New Zealand jurisdiction.  

 

 

Note: The maximum file size that you can      
          upload at one time is 200 MB (whether it is  
          one 200MB file or several files add to a total  
          200MB maximum). 
 
          For more help regarding uploading your 

screencasts and videos to Cecil, please 
contact Cecil helpdesk, ext. 85100, email: 
cecilhelp@auckland.ac.nz 

mailto:web-request@lbr.auckland.ac.nz
http://creativecommons.org/
http://creativecommons.org/about/licenses
http://creativecommons.org.nz/
mailto:cecilhelp@auckland.ac.nz
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9.2 Embedding a CCANZ License 
into a webpage 

 

The Creative Commons License copyright 

information is usually embedded in the 

webpage where your video is streamed 

from. It is rarely embedded in a video file 

itself. For example, the Library‟s Study and 

Research Help (http://www.library.auckland.ac.nz/instruct) webpage contains the Creative 

Commons License created for Library instructional videos. 

 

To license newly created and publicly available digital content go to the Creative Commons 

Website: http://creativecommons.org/license/?jurisdiction=nz, fill in the required 

information and click Select a License. 

 

http://www.library.auckland.ac.nz/instruct
http://creativecommons.org/license/?jurisdiction=nz
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On the following screen you can view the license that complements the information you 

have indicated, and how it will be tagged or displayed on a webpage. Here you can also 

copy the HTML code of your license and paste it in the Code view of the website in 

Dreamweaver. 

 

The Creative Commons License for your 
video according to the specifications you 
have selected on the previous page. You 
can select how it will be displayed on a 
webpage (3 versions). 

   Help & advice: 

For more information 

about the CCANZ and 

advisory help regarding 

creating the Creative 

Commons License for your 

online products, please 

contact Leonie Hayes, , 

ext. 87942, email: 

l.hayes@auckland.ca.nz 

 

mailto:l.hayes@auckland.ca.nz
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Here is the HTML code for the complete license, including the license tag/image.  

1. Select the complete HTML code 

2. Copy it 

3. Open the webpage in Dreamweaver CS5, where your video is displayed or uploaded 

4. Select the Split/Code view 

5. Scroll down the website HTML code 

6. Place the cursor to the position of the webpage where you‟d like the CC License to 

display 

7. Click Paste 

8. Click Save 

9. Preview the webpage and the CC License in browser 

10. Email web-request@auckland.ac.nz and ask for the modified page to be uploaded 

onto live server. 

  

8.3 Embedding a CCANZ License into Microsoft Office files 

 

For embedding Creative Commons Licenses directly into Microsoft Office files, please refer 

to this site for details: 

http://www.microsoft.com/downloads/details.aspx?FamilyId=D1DDBDC8-627F-415A-9B0A-

97362BC9B480&displaylang=en 

 

 

9. Further help - BBFlashBack online tutorials  

 

 How to record the screen: http://www.bbsoftware.co.uk/mm/HowToRecord2.htm 

 Editing and enhancing your video: http://www.bbsoftware.co.uk/mm/Editing2.htm  
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